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Key Summary of the E-Filing Process

This summary shows you the process involved to E-File your data.
Whatever you E-file, the steps remain the same.

• RTI – FPS, EPS, NVR, EYU

Step 1 Sign Up/Sign In.

Step 2 Download the given spreadsheet
template from our website

Step 3 Populate the data from your
system into the given spreadsheet.

Step 4 Assign a filename to the
spreadsheet and save it in a CSV
file format.

Step 5 Sign in to our website and select
Upload CSV File from the top
menu bar.

Step 6 Click on the Browse button to find
the CSV file that you just assigned
a name to and then upload the
same CSV file.

Step 7 E-file the uploaded file by clicking
E-File Now!, or amend the file
based on the error report provided
and upload the file again.

Step 8 Print the E-filing Certificate and
view reports.

( More information about each of the steps is detailed below. )

Support Email: sales@efileready.com Tel: 020 8452 9516



1 Conducting RTI Tests (How To)
To test the RTI services, you have to sign up with us. The sections below will help you to
understand the steps involved in creating a TEST account and E-filing the RTI returns to HMRC
from eFileReady.

1.1. Where and How to Sign Up for a LIVE TEST Account
To create a Test Account on eFileReady, go to http://efileready.com, and click on 'SIGN UP FOR
TEST ACCOUNT' button in the eFileReady home page.

Fig 1.1 E-Fileready Home Page

Alternatively, click the following link – http://test.efileready.com. Then click Sign Up and follow the
screens to sign up for a test account. You will receive an E-Mail containing an activation link.

Click the link within the e-mail and set up your sign in details for your test account After your test
account has been created, sign In to the TEST account from the link http://test.efileready.com.

Road Map:

Click on activation link → Set up your Sign In security details (password, pattern word etc.) →
Final Confirmation

After a successful sign up process, you can sign In to your account with your credentials - User ID,
e-mail ID, password, and pattern word. Each time you sign in you will be asked to enter your Sign
In credentials.

https://www.efileready.com/
https://test.efileready.com/
https://test.efileready.com/


Fig 1.2 Test Account Sign In

1.2. Test Credentials Setup for E-Filing

1.2.1 Test Credentials Setup
​ By default eFileReady has pre-entered eFileReady's own HMRC Agent ID and Password

ready for you to use to E-File your test RTI forms including FPS, EPS, NVR, EYU. You do
not need to use your own PAYE credentials.

​ To view eFileReady's own test credentials, go to Employer/Contractors in the menu bar and
click E-filing Credentials Setup. Further click the 'HMRC RTI FPS, EPS, NVR, EYU' link. On
the next page by default the eFileReady's Agent Credentials will be provided as shown in
Fig 1.3



Fig 1.3 E-Filing Setup

1.2.2 Using your own Software Developer Test credentials

Your own Software Developer Test credentials obtained from HMRC can be used for testing the
RTI E-filing services of eFileReady. To apply for your own Test Credentials please contact the
Software Developers Support Team (SDS Team).

To set up your own Software Developer test credentials in eFileReady go to the
Employer/Contractors section on the menu bar and click E-filing Credentials Setup. Further click
the 'HMRC RTI FPS, EPS, NVR' link.

​ Then select 'EMPLOYER' (see fig 1.3) or 'I am an AGENT' as appropriate and enter your
Software developer Test credentials ( Test HMRC User ID and password ) provided by
HMRC by clicking on the Edit button and later on the Save button.

​ Alternatively, you can use the following test credentials for Submission of FPS, EPS, NVR
etc.

PAYE Reference : 548 / A548 ( to be included in the FPS or EPS file )



User ID : ISV548

Password : testing

1.3. How to download the RTI spreadsheet
Download the spreadsheet for the respective RTI return. Save them all as CSV files and further
proceed with uploading the files. The upload process is explained in detail in the further sections.

NOTE : The guide remains same for all RTI forms including FPS, EPS, EYU, NVR

To download the PAYE RTI FPS, EPS, EYU & NVR Test Data spreadsheets to your local system,
please follow the road map below.

Road Map:

Download Spreadsheet → Download Sample Live Test Data → Download PAYE RTI Spreadsheet
(CSV) Test Data → Download RTI FPS TEST Data

Fig 1.4 Download Sample Test Data



Fig 1.5 Download Test Data Spreadsheet

Now click the 'Download RTI FPS TEST Data' link to download the FPS test spreadsheet onto your
local system. Please follow the same steps to download the EPS, EYU and NVR Test Data
spreadsheets to your system.

IMPORTANT NOTE : If you are using eFileReady's credentials for the Test E-filing please do not
change the PAYE Reference column containing the value 548/A548 in the spreadsheet.

If however you are using your own Employer or Agent credentials for the test E-filing please do
amend the PAYE Reference 548/A548 to your own Test PAYE Reference.



1.4. How to Upload the RTI Files.

1.4.1 Select Upload CSV/XML File from the menu bar
You can now upload the test data file to eFileReady. Please follow the below road map to upload
RTI test files.

Road Map:

Upload Data → Upload RTI - FPS, EPS, NVR,FSY, Additional FPS, EYU. → Click appropriate
Upload RTI CSV/XML File link

Fig 1.6 Upload Data



Now click the 'FPS CSV File' Link to upload the FPS CSV file.

Fig 1.7 Upload RTI Data



1.4.2 Browse to find the CSV file and then upload that CSV file
Enter the Employer name and pick up the FPS CSV spreadsheet file you just saved in your local
system by clicking on the 'Browse' button (in just the same way as you sign in to an e-mail account
and then go to your local system to pick up a file you prepared previously to attach to an e-mail).

Fig 1.8 Browse CSV File

Enter a reference of your choice for the CSV file you are uploading. This is optional, you can leave
it blank.

Now click the 'Upload CSV File' button to upload the file to the eFileReady server.

(NOTE: Do not click the screen while the upload is in progress because it might interrupt the
upload.)

As you upload your CSV files, our service instantly converts the files into XML and validates them
against the HMRC provided SCHEMA and BUSINESS RULES, ready for E-filing.

If no errors are found in the uploaded data, you will see a successfully uploaded message on the
screen as shown in Fig 1.9



Fig 1.9 Upload Successful

If errors are found, an Error Report will be displayed on screen as shown in Fig 1.10. You should
amend the errors as indicated and then start the process again.

Fig 1.10 Upload Report

Please follow the same process as above to upload RTI EPS, EYU, and NVR spreadsheets to
eFileReady.



1.5. How to E-File RTI Data to HMRC

1.5.1 E-Filing the uploaded RTI- FPS, EPS, EYU and NVR data to HMRC
To E-File your uploaded RTI data to HMRC, go to E-filing on the tasking zone and click E-File
PAYE RTI FPS, EPS, EYU, NVR.

Road Map :

E-filing → RTI - FPS, EPS, NVR,FSY, Additional FPS, EYU → E-file RTI uploaded data → E-file
Selected → Enter user Sign In password → E-File Now

Fig 1.11 E-File Data

Before E-filing your data to the HMRC, you should double check to ensure that the data you have
uploaded is correct. To view and check the uploaded data before E-filing, simply click the View /
Print link. If the upload is correct, select the upload you wish to e-file by selecting the appropriate
box, then click on the 'E-file Now' button. Enter your name and sign in password in the Employer's
Declaration page.



Fig 1.12 E-File RTI Data

Fig 1.13 E-File RTI Data

The below screen will be displayed as your data is being sent to the HMRC. There may be a delay
before you receive a response from the HMRC, especially at peak times. Fig 1.13 E-Filing in
Progress

Please note, the E-filing done on the Test eFileReady server is only for Testing purposes. You
cannot e-file your actual Live Returns through Test eFileReady. To e-file your actual returns to
HMRC, please sign up for our Live eFileReady account on www.efileready.com.

https://www.efileready.com/


1.6. How to Check the E-Filed Status
Once the data is submitted to HMRC an E-Filing Certificate is generated from HMRC which you
can view in the Reports section. Fig 1.15 displays the status of your E-filing of data to HMRC. The
status can be Initiated, Processing, Submitted and Completed. Please keep checking the
status. Road Map : Reports → View/Print Your E-Filed Returns and Others

Fig 1.14 E-Filed Status

If you get an authentication failure, please check your Test credentials, correct them and e-file
once again. Please follow the same steps as explained above for successful E-filing. To view the
E-Filed certificate, click the View/Print link under the E-Filed Certificate. Then click on 'Print
Certificate' to print the certificate.



Fig 1.15 E-Filed Certificate



2 Conducting RTI Live Submissions
2.1. Where and How to Sign Up for a RTI Live Account
Click the following link http://www.efileready.com/ to sign up for a Live account.

2.1.1 Live Credentials Set Up
eFileReady's own E-filing credentials are pre-entered and selected by default ready for you to use
to E-File your RTI forms live.

However, If you wish to use your own details, go to Employer/Contractors on the menu bar and
click E-filing Credentials Setup. Further click the 'HMRC RTI FPS, EPS, NVR, EYU' link, and select
either 'I am an EMPLOYER' or 'I am an AGENT/BUREAU' to enter your own HMRC ID and
Password credentials provided by HMRC.

2.1.2 How to E-file Live RTI Files to HMRC
1. Please download the RTI Spreadsheets – FPS, EPS, NVR from Download Spreadsheet in

the tasking zone.

2. Populate your data into the spreadsheet and save the file in a CSV/XML format locally into
your system.

3. The rest of the process for uploading CSV/XML files, E-filing the uploaded RTI data to
HMRC and checking the success status remains the same as in RTI Test E-filing. Please
refer to section 1.4 How to Upload the RTI Files. and 1.5 How to E-File RTI Data to HMRC

3 How eFileReady helps with filing the RTI Submissions to
HMRC online
The RTI E-filing process has been simplified in the eFileReady application. We have tested against
the available HMRC's RTI TEST Server and the BACS system, and so far all tests have been
successful. We are ready and able to give you all the help and support you need when you come
to fulfilling the HMRC's RTI requirement.

Using eFileReady you can E-File the RTI returns to HMRC using a simple spreadsheet. All you
need to do with RTI is to extract the data from your payroll system and place it in a simple
spreadsheet template provided by us. Different RTI returns require different spreadsheet templates
which are all freely available from our website. Our www.efileready.com system will convert your
spreadsheet (CSV/XML file) into the HMRC's required XML format and then e-file your RTI data
automatically. Our system will also automatically produce BACS files embedded with 4 Character
Random Strings and FPS files embedded with correlated HASH CODES.

Our RTI system is fully tested and ready to go. You can test it against the HMRC's TVPS test
server or your BACS system today. As the system is platform independent it will work seamlessly
with whatever payroll or BACS system you have.

3.1. RTI Submissions supported by eFileReady

3.1.1 Full Payment Submission (FPS)
You need to make an FPS return whenever you make a payment to an employee, be it monthly,
weekly, 2 weekly or 4 weekly etc. Each pay frequency has its own respective FPS return.

https://www.efileready.com/
https://www.efileready.com/


Unique Services:

eFileReady will provide a BACS file with the 4 character random string entered, and where
supported, the corresponding HASH CODE for FPS, all of which are based on HMRC
specifications.

The Full Payment Submission (FPS) will have the HASH CODE ( including the 4-character random
string ) as required by HMRC.

Fig 3.1 FPS

3.1.2 Employer Payment Submission (EPS)
This is a monthly return submitted when claiming from HMRC for Statutory Payments to
Employees, CIS Deductions Suffered and other claim items.

Fig 3.2 EPS

3.1.3 NINO Verification Service (NVR)
This allows employers to validate or obtain a new employee NINO. Simply download the template
from www.eFileReady.com and then upload it back to eFileReady to e-file the details. After Efiling
you need to log on to www.eFileReady.com to view and/or download the responses from HMRC.
The process is conducted through something known as the Data Provisioning Service (DPS). You
can download the response in a CSV or XML file format to upload directly to your system to update
your employees' NINO.

https://www.efileready.com/
https://www.efileready.com/


Fig 3.3 NVR

3.1.4 Earlier Year Updates (EYU)
You can submit an Earlier Year Update (EYU) to correct FPS information for up to six years after
you filed your original FPS. If you are correcting an error in a previous tax year when you used
FPS, your EYU should only record the difference between what you had originally submitted and
what the figure should be. For example, if you recorded £100 on an employee's payroll record, the
EYU should show '+£100'. You can only amend year to date data on an EYU.

3.2. Correction of Error Data
If you have noticed any errors in the data you have already e-filed, you can update the data with
correct values and re-submit to HMRC via eFileReady. Whether you have made mistakes in FPS
or EPS, there are solutions to rectify those and e-file once again. The correction procedures are
different for current tax year data and previous tax year data.

3.2.1 Current Tax Year Data Correction

3.2.1.1 Correction of FPS Data using Additional FPS
An Additional FPS return is an extra FPS you may file, in addition to the regular FPS file you have
just completed, to rectify any errors you may have just discovered. The purpose is for you to make
up any under payment, or cancel a payment, or rectify any over payment you may have just made.
It is to be used under the following strict conditions :

​ It can be used only when the error of under payment, canceled payment, or over payment,
is discovered when you are still in the same pay period in which the error was made.

​ It can only be used if you are in the new pay period but you have not yet e-filed the FPS file
of the new pay period, ie you are allowed to rectify immediate past pay period errors
provided the current pay period FPS file has not yet been filed.

​ You can NOT use it to amend errors that occurred more than one pay period ago, eg. if you
are in month 7 you definitely can NOT use an Additional FPS to amend any data errors that
occurred in pay period 5 or earlier.

​ Errors which occurred more than one pay period ago can be left alone so long as in the
next FPS return you bring all the payment and YEAR TO DATE data up to date.
Alternatively you may file an Earlier Year Update if the errors belong to a previous tax year.



Please follow the below road maps to e-file the additional FPS to HMRC.

Road Map : Download Additional FPS Spreadsheet

Download Spreadsheet → PAYE RTI FPS, EPS, NVR, FSY, Additional FPS, EYU Template
Download → Download Spreadsheet - Additional FPS Returns → Download PAYE RTI Additional
FPS Returns Spreadsheet

Road Map : Upload Additional FPS Spreadsheet

Upload Data → Upload RTI FPS, EPS, NVR, FSY, Additional FPS, EYU → Additional FPS Return
(CSV/ XML) → Browse → Upload File

Road Map : E-File Additional FPS

E-Filing → E-File PAYE RTI FPS, EPS, NVR, FSY, Additional FPS, EYU → E-File Additional FPS
(Full Payment Submission) Uploaded Data → Select the File → E-File Selected → Enter User
Sign In Password → E-File Now

3.2.1.2 Correction of EPS Data (Current Tax Year)
EPS data e-filed in the current tax year can be corrected by e-filing another EPS to HMRC. The
latest EPS values will overwrite the wrong figures e-filed before.

3.2.2 Previous tax year data correction

3.2.2.1 Correction of FPS Data using EYU
You can submit an Earlier Year Update(EYU) to correct FPS information for up to six years after
you filed your original FPS. If you are correcting an error in a previous tax year when you used
FPS, your EYU should only record the difference between what you had originally submitted and
what the figure should be. For example, if you recorded £100 on an employee's payroll record, the
EYU should show '+£100'. You can only amend year to date data on an EYU.

Road Map : Download EYU Spreadsheet

Download Spreadsheet → PAYE RTI FPS, EPS, NVR, FSY, Additional FPS, EYU Template
Download → Download Spreadsheet - RTI EYU (Earlier Year Update) → Download PAYE RTI
EYU (Earlier Year Update) Spreadsheet

Road Map : Upload EYU Spreadsheet

Upload Data → Upload RTI FPS, EPS, NVR, FSY, Additional FPS, EYU → Earlier Year Update
(EYU)(CSV/ XML) → Browse → Upload File

Road Map : E-File EYU Data

E-Filing → E-File PAYE RTI FPS, EPS, NVR, FSY, Additional FPS, EYU → E-File EYU (Earlier
Year Update) Uploaded Data → Select the Employer → E-File Selected → Enter User Sign In
Password → E-File Now

3.2.2.2 Correction of EPS Data (Previous Tax Year)
EPS data e-filed in the previous tax year can be corrected by e-filing another EPS to HMRC. The
latest EPS values will overwrite the wrong figures e-filed before.



3.3. RTI HASH and BACS
The HASH including random string is a cross reference which will allow HMRC to match the RTI
data received with payments made via BACS.

There are two parts to the cross-reference:

(a) a hash (including random string) in the RTI FPS submission to HMRC;

(b) a random string inserted in field 7 of the BACS payment instruction.

Employers paying their staff using Bacstel-IP must include a HASH (including random string) in
their RTI FPS submission. The associated random string must be included in their BACS payment
instructions.

3.4. How eFileReady generates the HASH Code
eFileReady will automatically produce BACS files embedded with 4 Character Random Strings and
FPS files embedded with correlated HASH(including random string). Later HMRC can then match
the hashes returned with the RTI data against hashes generated during payment file processing for
compliance cross checking purposes.

eFileReady provides the below options for BACS HASH Code submissions in RTI FPS returns to
HMRC.

​ If the Payroll Software generates the BACS HASH (including random string), they can be
entered in to FPS spreadsheet.

Then there is no requirement to enter Bank Details for the Employer and Employee. This
can be advantageous to some Employers with particular requirements.

​ If eFileReady is to be used for generating BACS as well as the FPS files, then all the BACS
related columns should be populated. The below mentioned columns must be filled in the
FPS spreadsheet.

​ Employer BACS Service User Number

​ Employer Name in Bank Account

​ Employer Bank Sort Code

​ Employer Bank Account No

​ Employee Name in Bank Account

​ Employee Bank Sort Code

​ Employee Bank Account No

​ BACS Payment Description

Please note, once the file has been successfully uploaded, you can then download the BACS
output file. Currently the default BACS output is in Standard 18 format.

Other BACS Output Formats Supported are :-

1. ALBANY Standard

2. Barclays BIB - CSV

3. NatWest / RBS Standard

4. NatWest Bulk List

5. BACS Standard 18

6. ABM BACS



7. BottomLine Standard 18

8. TransGlobal BACS

9. HSBCnet - Hex4W(UK) BACS

10. Bankline BACSTEL-IP - NatWest Ad hoc – SPD

11. Bankline BACSTEL-IP - NatWest Ad hoc – MPD

12. Santander Connect

13. Clydesdale & Yorkshire BACS

14. NatWest PayAway

15. Lloyds Bank BACS

4 Download notices from the HMRC's DPS (How it works)
Other than E-filing services, www.efileready.com can also be used to download your P6, P9, SL1,
SL2 etc. (CSV/XML/EDI GFF) documents from the HMRC's Data Provisioning Service (DPS). This
allows you to conduct auto tax code updates.

The HMRC DPS Server allows users to download their data in two different approaches:

• Ongoing Incremental Approach

• Date Defined Approach

Our system has been tested and certified to work perfectly with both approaches.

• Ongoing Incremental Approach:

This allows you to download your respective notices on an ongoing basis. i.e. only the new and
latest notices will be downloaded each time you give it an instruction. The eFileReady Gateway
Server has incorporated this design into its software architecture, helping you to store whatever
you downloaded previously in its server in an orderly manner. You can view and print your
historical notices at anytime for up to 3 years over the net.

• Date Defined Approach:

You can retrieve your current and historical data from the HMRC Server by entering your
requirement into the eFileReady Gateway Server. Should your system crash, you need not worry
because you can always retrieve the data again from the DPS. The eFileReady Gateway Server
allows you to retrieve your data from any historical period in the current tax year.

The range of documents that can be downloaded include:

​ P6, P9 Tax Code Change Notification

​ NINO and RTI Notification

https://www.efileready.com/


​ CIS Notification

​ SL1, SL2

​ NOT – P11(b) Notification

​ AR

​ PGL1, PGL2

For better understanding about how to download notices from HMRC's DPS via eFileReady,
please follow the step by step guidance below.

4.1. Setup HMRC E-Filing Credentials in eFileReady
In order to access any of DPS (Data Provision Service ) services, you must be registered with the
HMRC for PAYE Online Services and must enter your HMRC User ID and Password into our
system and then save it. If you do not have HMRC User ID and Password, you need to create one
and then setup the credentials in eFileReady. Click here to apply for HMRC e-filing credentials.

Please follow the below road map to setup the e-filing credentials in eFileReady.

Road Map:

Employer / Contractor Details → E-filing Credentials Setup → DPS - P6, P9, SL1, SL2 etc. →
Edit → Select user type (EMPLOYER or AGENT / BUREAU) → Enter credentials → Save

Fig 4.1 E-Filing Credentials Setup

Select the appropriate user type(EMPLOYER or AGENT/BUREAU) and then click on 'Edit' button.

https://www.gov.uk/log-in-register-hmrc-online-services/register


Fig 4.2 DPS Setup



Fig 4.3 E-filing Setup

4.2. Login to HMRC DPS site via eFileReady.
Once you setup the HMRC e-filing credentials, you can directly access and download the notices
from HMRC. Our service enables you to login to HMRC and download the ongoing notices such as P6,
P9, SL1, SL2,PGL1, PGL2 Expenses & Benefits, and End of year returns notices. You are also
provided with the facility to view and download the notices in CSV format onto your local system.

Road Map:

DPS → DPS for P6,P9,SL1,SL2,NINO & RTI → Select the appropriate notice → Enter User Sign
In Password → Login to HMRC



Fig 4.4 View/Download DPS

Fig 4.5 Login to HMRC



4.3. View / Download DPS for P6, P9, SL1, SL2, NINo and RTI
Through eFileReady, you can download your P6, P9, SL1 and SL2 as well as other available
forms, from the HMRC DPS. You will be able to download only the latest notices i.e. those which
have not been downloaded before. You can download the respective data in a CSV format, to
conduct auto-tax code updates. You can also download these files in GFF formats.

From 2019 new two notices i.e. PGL1 (Start Post Graduate Loan deductions) and PGL2 (Stop Post
Graduate Loan deductions) are started along with the existing notices from HMRC.

Road Map:

Select Form → Click on Confirm Download → View / Download ongoing notices → Click on
Download ( CSV or EDI GFF)

Fig 4.6 Confirm DPS Download



Fig 4.7 View / Download Ongoing Status

NOTE : You will receive a reminder called as generic notification from HMRC for your late
reporting, late payments and NVR Returns. Through eFileReady you can also view/download RTI
Generic notifications. These notifications can be downloaded in GFF format. Click here for more
information.

Click on the View/Print link under 'GEN NOT Details' to download the generic notification.

Fig 4.8 Generic Notification

https://www.gov.uk/guidance/what-to-do-if-you-get-an-online-penalty-warning-message


4 Other E-Filing Services
( Automated E-filing to HMRC at anytime over the Internet )

1. E-filing of CIS 300 Monthly Returns

2. Verification of Subcontractors' Tax Status

3. E-filing of Pension and other returns

4. Data Provisioning Services (DPS) Downloading

5. E-filing of P11D, P11D(B), P46(CAR)

6. E-Filing of CT and iXBRL Accounts to HMRC

7. E-Filing of Companies House iXBRL Accounts

Click here to log on to www.eFileReady.com

( For more information about our products and services, please contact our Support Team. )

Support Email: sales@efileready.com Tel: 020 8452 9516

https://www.efileready.com/

