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1. Create Live eFileReady account
To start using our MTD VAT e-filing service, you will need to sign up with us. The sections below
will help you to understand the steps involved in creating a LIVE account and e-filing the MTD VAT
returns to HMRC from eFileReady.

1.1 Where and how to sign up for a LIVE account
To create a live account in eFileReady, go to http://efileready.com, and click on 'SIGN UP' button in
the eFileReady home page.

Figure 1.1 eFileReady sign up

Click Sign Up and follow the screens to sign up for a live account.

You will receive an e-mail containing an activation link. Click the link within the e-mail and set up
the sign in details for your account.

Road Map:

Click on activation link → Set up your Sign In security details (password, pattern word etc.) →
Final Confirmation

After your live account has been created, sign in to the LIVE account from the link
http://efileready.com. Enter your sign in credentials (User ID, e-mail, password and pattern word) to
sign in to your account. Each time you sign in you will be asked to enter these credentials.
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Figure 1.2 Sign in
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2. MTD VAT authorisation setup
Authorisation for MTD VAT return is a mandatory setup you will need to do to enable MTD VAT
return e-filing to HMRC via eFileReady. After successful sign up process, login to eFileReady and
go to Employer / Contractor menu in the tasking zone and select 'MTD VAT Authorisation Setup'.

Please follow the below road map for MTD VAT authorisation setup.
Road Map:
Employer / Contractor → MTD VAT Authorisation Setup → Proceed to HMRC for MTD VAT
Authorisation

Figure 2.1 MTD VAT authorisation setup
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Figure 2.2 Proceed to MTD VAT setup
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2.1 Grant Authority
Subsequently you will be redirected to HMRC's website to complete the MTD VAT Authorisation.
Complete the Authorisation process with your MTD User ID and Password. After successfully
finishing the steps on HMRC's website, you will be then taken back to eFileReady to continue with
e-filing related tasks.

Figure 2.1.1 Authority to interact with HMRC
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Figure 2.1.2 user sign in

Figure 2.1.3 Grant authority
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3. Methods of transferring files to eFileReady
Once the authorisation process is completed, you will need to upload the MTD VAT file to
eFileReady. Our system allows you to easily transfer VAT data extracted from any
ERP/Accounting/VAT system. It acts as a digital link between your current system and HMRC's
MTD VAT system. We provide you the following options to upload the MTD VAT data.

​ Manual upload method (Refer section 4. Manually upload and e-file MTD VAT data)
​ SFTP method ( Refer section 5. Upload and e-file MTD VAT data via SFTP )

You can choose any of the above methods to transfer your MTD VAT data to eFileReady. Our
inbuilt intelligent system will then convert the uploaded VAT data into the required MTD VAT data
format. Further our system will e-file the data to HMRC through the MTD VAT API.

4. Manually upload and e-file MTD VAT data
In this method, you can manually upload the populated data file into eFileReady. Our system will
accept the VAT data in CSV file formats. You can also extract the VAT data from the accounting
package or specialist VAT software calculator directly. The system will support batch upload i.e.
VAT data of multiple clients in the same file.

Following are the steps involved in uploading and e-filing your MTD VAT return CSV file.

Step 1: Download spreadsheet from eFileReady
You can download the CSV spreadsheet template from our system to populate the MTD VAT data.
Follow the below road map to download MTD VAT template.

Road Map:
Download Spreadsheet → MTD VAT Template Download → Download MTD VAT Return
Spreadsheet
We recommend you to download and read the instructions before you populate your data into the
spreadsheet.
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Figure 4.1 Download spreadsheet

Once downloaded, you should enter your data into the spreadsheet and save it in a CSV format.

NOTE : It is not necessary to use eFileReady provided template. You can also upload the VAT data
extracted from your accounting system in the accepted format (CSV format).
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Step 2: Browse and upload the CSV file
The next step is to upload the populated VAT data spreadsheet into eFileReady. Please follow the
road map below:

Road Map:
Upload Data → MTD VAT Upload → Upload MTD VAT Return CSV File → Browse → Upload
CSV File

Figure 4.2 MTD VAT Upload

Pick up the MTD VAT return CSV spreadsheet file you saved in your local system by clicking on
the 'Browse' button. Enter a reference of your choice for the CSV file you are uploading (This is
optional, you can leave it blank). Then click on 'Upload CSV File' button to upload the file to the
eFileReady server.
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Figure 4.3 Browse and upload MTD VAT data
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Figure 4.4 MTD VAT upload data report

NOTE: Do not click the screen while the upload is in progress because it might interrupt the
upload.

If no errors are found in the uploaded data, an upload successful message will be displayed as
shown in Figure 4.4.
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Step 3: E-File MTD VAT return uploaded data to HMRC
Now you can review and e-file the uploaded VAT return file to HMRC. Please follow the road map
below to e-file MTD VAT return.

Road Map:
E-Filing → E-File MTD VAT → E-File MTD VAT Return Uploaded Data → Select to E-File Bulk →
E-File All → Declaration page ( Enter Name and Sign In Password ) → E-File Now

Figure 4.5 E-file MTD VAT
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Figure 4.6 Trader's declaration
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Step 4: Check MTD VAT return E-Filed status
Once the data is submitted to HMRC an E-Filing Certificate is generated from HMRC which you
can view in the Reports section. The status can be Initiated, Processing, Submitted and
Completed. Please keep checking the status.

Road Map :
Reports → View / Print your E-Filed Returns and Others → MTD VAT E-Filed Details

5. Upload and e-file MTD VAT data via SFTP
Our system will accept MTD VAT from any SFTP service you may use. We provide two options to
transfer the MTD VAT data into eFileReady server via SFTP. This method is much more time
saving than the manual method.

Once it is setup, you will just need to upload the file to eFileReady server. The system will pick up
the uploaded data from the SFTP location and pre-validate them for HMRC XML Schema data
conformance and business rules. Further, your MTD VAT data will be automatically e-filed to
HMRC. We will acknowledge you with the e-filing status e-mail at each level of processing.

The two options to transfer the MTD VAT data into eFileReady server via SFTP are the following.
​ SFTP setup for eFileReady provided SFTP services
​ SFTP setup for Others / Third-party software

5.1 SFTP setup for eFileReady provided SFTP services
This method is only for users who do not have their own SFTP server, but want to use SFTP mode
to transfer MTD VAT files to eFileReady. Such users can create SFTP account in eFileReady, and
further drop e-filing data into their SFTP account.

Any user of eFileReady, can create SFTP account within their account. You will receive HMRC
responses in a secure way. You can also get notifications and file processing status updates
through Email.

Action 1 : Log in to eFileReady application.
'eFileReady SFTP' setup is a one-time setup to create an SFTP account in eFileReady. For this,
log in to your account, and continue with the welcome page. You will then land on the 'Employer
Details' page. Go to “eFileReady SFTP SETUP → VAT” link.
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Figure 5.1.1 eFileReady SFTP setup

Action 2 : Request SFTP credentials

Click on “Request SFTP Credentials”, the fields SFTP Server Hostname / IP, SFTP Login User ID,
Input Folder Name, Output Folder Name will be auto-populated with values. These fields are
non-editable and generated by eFileReady. These are the details which you must later use to
connect to eFileReady SFTP server.

'Input Folder Name' is the folder where in you will drop the MTD VAT CSV files. 'Output Folder
Name', is the folder where in eFileReady will drop the Status responses (in JSON format).

Fill in the SFTP Login Password of your choice and re-enter the password for confirmation
purposes. Fill in the Email details, that is the Emails to which eFileReady will send response details
with JSON attachments.
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Figure 5.1.2 Request SFTP credentials

Click on 'Save' and wait , eFileReady will create SFTP account with the given details, and connect
to your SFTP account. You will get an instant message on the page about the connection.
eFileReady SFTP account is ready for use now.

After successfully setting up eFileReady VAT SFTP credentials, a page will be displayed as shown
in Figure 5.1.3.
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Figure 5.1.3 SFTP details
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Action 3 : Download SFTP configuration file for FileZilla
To upload files using SFTP you will need an SFTP client software service provider to connect to
eFileReady SFTP server. Following are the instructions to connect FileZilla client software to
eFileReady SFTP server.

Click on “Download SFTP Configuration for FileZilla” button. An XML format configuration file
will be downloaded immediately. eFileReady provides the configuration file for each of the FTP
users. This file can be directly imported to FileZilla to configure SFTP.

Figure 5.1.4 Download SFTP Configuration for FileZilla

Action 4: Download and install FileZilla
We recommend you to download the latest version of FileZilla. Click on the link below to download
the latest version.
https://filezilla-project.org/download.php?show_all=1

Once downloaded, proceed to install FileZilla.

Action 5 : Import configuration file to FileZilla
Open FileZilla to import the downloaded configuration file.
1. Go to File → Import
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Figure 5.1.5 Import

2. Browse the configuration file. Select the eFileReady configuration XML file. Click “Open” →
Click “OK”

Figure 5.1.6 Open configuration file
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Figure 5.1.7 Import settings

Once the import process is completed, an “Import Successful” message will be displayed. The
eFileReady SFTP site will be created. Now proceed to establish the SFTP connection to
eFileReady.

Action 6 : Establish SFTP connection

1. Go to File → Site Manager.

Figure 5.1.8 Site Manager

.
2. Select the eFileReady SFTP Server from the “My Sites” list. All the credentials will be
automatically extracted from the configuration file.
3. Click on “Connect” to establish SFTP connection and transfer your files to eFileReady.
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Figure 5.1.9 Establish SFTP connection

Action 7 : Transfer MTD VAT CSV file to eFileReady server
Once the connection is established, you can transfer the MTD VAT CSV file from your local
directory to the eFileReady SFTP server. To transfer, you'll need to drag and drop the file to the
appropriate folder.
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Follow the steps to upload files to eFileReady SFTP server

1. First, drag and drop the MTD VAT CSV file to the “inbox” folder( Refer Figure 5.1.10).

Figure 5.1.10 Drag and drop file to inbox folder

2. Check the file transfer status from the information window of FileZilla( Refer Figure 5.1.11). If

status is displayed as “Successful” you can continue with the following steps.

3. Your CSV data file will be taken for processing, immediately after the transfer is successful.

4. The system will automatically proceed for e-filing, if the data validation of your CSV file has no

errors. You'll be further acknowledged with the e-filing status e-mail at each level of processing.
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Figure 5.1.11 Check file transfer status

5.2 SFTP setup for Others / Third-party software
This method is only for users of Third-party software which are capable of having their own SFTP
server, and want eFileReady to connect to their server and perform file transfer and file processing
operations.

Any user of eFileReady can set up SFTP within their account by giving the Third-party SFTP
details. This means you can send HMRC Efiling data for MTD VAT and receive HMRC responses
in a secure way. You can also get notifications and file processing status updates through e-mail.

The steps below will explain how you can configure 'Other SFTP' Setup :
'Other SFTP' Setup is a one-time setup to link eFileReady with your SFTP location. For this, log in
to your account, and continue with the welcome page. You will then land into the 'Employer
Details' page.
1. Go to “Other SFTP SETUP → VAT” .
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Figure 5.2.1 Other SFTP setup

2. Enter the details for SFTP Server Name and SFTP Login User ID.
3. Further, enter the “Input Folder Name”, that is the folder wherein you or the third-party software
will drop the VAT CSV files.
4. Also, enter the “Output Folder Name”, the folder wherein eFileReady will drop the status
responses (in JSON format).
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Figure 5.2.2 SFTP details

5. Fill in the SFTP login password and re-enter the password for confirmation purpose. Fill in the
Email details, that is the e-mails to which eFileReady will send response details with JSON
attachments.
6. Click on “Save” and wait. eFileReady will then connect to your SFTP location with the given
details, and give you a message page if the connection could be established or not.

If the message is positive, the SFTP connection is successfully done. You can proceed with
uploading files to the 'Input Folder' location. If not, check the details entered, and verify if the folder
names given by you have appropriate permissions. Further you can retry the setup after corrective
action is taken as required.
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5.3 When will the files be processed?
eFileReady will pick the files dropped in 'Input Folder' for processing , instantly.

5.4 MTD VAT sample e-mail screenshots

Figure 5.4.1 Initiated Email
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Figure 5.4.2 In Progress Email

Figure 5.4.3 Completed Email
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5.5 MTD VAT monthly return JSON samples
{

"correlationId":"9646022F08B9E43DADAEB2A6943428FE",

"statusCode":"initiated",

"stage":"",

"status":"Data processing is initiated.",

"successTimestamp":null

}

{

"correlationId":"9646022F08B9E43DADAEB2A6943428FE",

"statusCode":"in_progress",

"stage":"submission_initiated",

"status":"Data submission is initiated.",

"successTimestamp":null

}

{

"correlationId":"9646022F08B9E43DADAEB2A6943428FE",

"statusCode":"completed",

"status":"Data processing is completed without any errors.",

"providerId":"HMRC",

"providerRefId":"5b7a5b0e10000025003b43b9",

"providerMessage":"Receipt-Id : f9d81f31-0164-48d1-b7ec-11c8477578f0 ,

Receipt-Timestamp : 2023-08-20T06:09:18.733Z",

"responseDetails":{"processingDate":"2023-08-20T06:09:18.733Z",

"paymentIndicator":"BANK",

"formBundleNumber":"340071976932",

"chargeRefNumber":"NgEyTYvDs9RcmLE4"

}

}
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6. Download success certificate and reports
After successful e-filing we will issue a success certificate which includes HMRC's provided
Timestamp and Receipt-Id. You can also download the e-filed data status in a PDF/CSV format for
the selected period. In addition, our system will also store your data for up to 3 years.
Please follow the road map below to view / print the success certificates and reports.
Road Map:
Reports → MTD VAT E-Filed Details → MTD VAT E-Filed Status List → Print Certificate

Figure 6.1 Download success certificate and report

Figure 6.2 MTD VAT e-filed status list
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Figure 6.3 Sample digital certificate
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